libadwaita

[full]

Building blocks for modern GNOME applications

The libadwaita C library provides building blocks for modern GNOME applications.

Usage

To start using libadwaita in your project, add the following depends value to your manifest, adjusting the version constraint as appropriate:

depends: libadwaita ^1.5.0

Then import the library in your buildfile:

import libs = libadwaita%lib{adwaita}

Importable targets

This package provides the following importable targets:

lib{adwaita}
lib{gtk-4}
lib{glib-2.0}
lib{appstream}

Importable targets description

license LGPL-2.0-or-later
project libadwaita
url gitlab.gnome.org/GNOME/libadwaita
doc-url gnome.pages.gitlab.gnome.org/libadwaita/doc/1.5/
1 Version
version 1.5.0+4
repository https://pkg.cppget.org/1/queue/testing
depends 0